aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-04-11 10:19:20 +0200
committerhozan23 <hozan23@karyontech.net>2024-05-19 13:51:30 +0200
commit0992071a7f1a36424bcfaf1fbc84541ea041df1a (patch)
tree961d73218af672797d49f899289bef295bc56493 /Cargo.toml
parenta69917ecd8272a4946cfd12c75bf8f8c075b0e50 (diff)
add support for tokio & improve net crate api
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 5 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ca73eeb..e8586b7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,20 +2,14 @@
resolver = "2"
# Please ensure that each crate comes before any other crate that depends on it
-members = [
- "core",
- "net",
- "p2p",
- "jsonrpc",
-]
+members = ["core", "net", "p2p", "jsonrpc"]
[workspace.package]
version = "0.1.0"
edition = "2021"
[workspace.dependencies]
-karyon_core = { path = "core" }
-karyon_net = { path = "net" }
-karyon_p2p = { path = "p2p" }
-karyon_jsonrpc = { path = "jsonrpc" }
-
+karyon_core = { path = "core", default-features = false }
+karyon_net = { path = "net", default-features = false }
+karyon_jsonrpc = { path = "jsonrpc", default-features = false }
+karyon_p2p = { path = "p2p", default-features = false }