aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-10-12 22:06:35 +0200
committerhozan23 <hozan23@karyontech.net>2024-10-12 22:06:35 +0200
commitc42258ff66eb4d17d5945a9fcacc4e5b07f8edea (patch)
tree14a609d1e52bf0236816ee9ad6c79f99f0d2043e /Cargo.toml
parentcae0c15d10235bf0ec0bd6f8b20814dc7b63dfd5 (diff)
Move the dependencies to the workspace cargo.toml file
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml55
1 files changed, 51 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b74b876..5205749 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,7 +14,54 @@ license = "GPL-3.0"
authors = ["hozan23 <hozan23@karyontech.net>"]
[workspace.dependencies]
-karyon_core = { path = "core", default-features = false }
-karyon_net = { path = "net", default-features = false }
-karyon_jsonrpc = { path = "jsonrpc", default-features = false }
-karyon_p2p = { path = "p2p", default-features = false }
+karyon_core = { path = "core", version = "0.1.6", default-features = false }
+
+karyon_net = { path = "net", version = "0.1.6", default-features = false }
+karyon_async_rustls = { path = "net/async_rustls", version = "0.1.6", default-features = false }
+
+karyon_jsonrpc = { path = "jsonrpc", version = "0.1.6", default-features = false }
+karyon_jsonrpc_macro = { path = "jsonrpc/impl", version = "0.1.6", default-features = false }
+
+karyon_p2p = { path = "p2p", version = "0.1.6", default-features = false }
+
+
+log = "0.4.21"
+thiserror = "1.0.61"
+chrono = "0.4.38"
+rand = "0.8.5"
+url = "2.5.2"
+parking_lot = "0.12.3"
+once_cell = "1.19.0"
+semver = "1.0.23"
+sha2 = "0.10.8"
+
+# async
+async-channel = "2.3.1"
+async-trait = "0.1.80"
+pin-project-lite = "0.2.14"
+async-process = "2.2.3"
+smol = "2.0.0"
+tokio = "1.38.0"
+futures-util = { version = "0.3.5", default-features = false }
+
+# encode
+bincode = "2.0.0-rc.3"
+serde = "1.0"
+serde_json = "1.0.117"
+base64 = "0.22.1"
+
+# macros
+proc-macro2 = "1.0"
+quote = "1.0"
+syn = "2.0"
+
+# websocket
+async-tungstenite = { version = "0.26.2", default-features = false }
+
+# tls
+rustls-pki-types = "1.7.0"
+futures-rustls = "0.26.0"
+tokio-rustls = "0.26.0"
+rcgen = "0.13.1"
+yasna = "0.5.2"
+x509-parser = "0.16.0"