aboutsummaryrefslogtreecommitdiff
path: root/core/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@proton.me>2024-03-20 15:20:21 +0100
committerhozan23 <hozan23@proton.me>2024-03-20 15:20:21 +0100
commit379dca552ca91d22ee007b42f93803ad3dc2b274 (patch)
tree1ba10573b6ec5213baf46f6ab9c3767e0daa4eed /core/Cargo.toml
parent340957fec147f4429796413f27bbd9b84ba6f141 (diff)
core: add the option to create a new task group without providing an
executor & remove GlobalExecutor type
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index 7e7e511..c8e2b8d 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -16,6 +16,8 @@ rand = "0.8.5"
thiserror = "1.0.58"
dirs = "5.0.1"
async-task = "4.7.0"
+async-lock = "3.3.0"
+async-process = "2.1.0"
ed25519-dalek = { version = "2.1.1", features = ["rand_core"], optional = true}