aboutsummaryrefslogtreecommitdiff
path: root/jsonrpc/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-05-20 00:56:08 +0200
committerhozan23 <hozan23@karyontech.net>2024-05-20 00:56:08 +0200
commit1836034374ba53677f5b72bdf8e3c976f97847af (patch)
tree52261ff14082f30911bc6ae4d4c9408fd190f6d4 /jsonrpc/Cargo.toml
parent059eed6ffa3a0ade449dfc5f5a7a97699e24394e (diff)
add metadata to Cargo.toml files
Diffstat (limited to 'jsonrpc/Cargo.toml')
-rw-r--r--jsonrpc/Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/jsonrpc/Cargo.toml b/jsonrpc/Cargo.toml
index ffab8bf..ce5c988 100644
--- a/jsonrpc/Cargo.toml
+++ b/jsonrpc/Cargo.toml
@@ -1,7 +1,13 @@
[package]
name = "karyon_jsonrpc"
+description = "A fast and lightweight async JSONRPC2.0 implementation."
version.workspace = true
edition.workspace = true
+homepage.workspace = true
+repository.workspace = true
+license.workspace = true
+authors.workspace = true
+
[features]
default = ["smol"]
@@ -29,7 +35,7 @@ karyon_net = { workspace = true, default-features = false, features = [
"tls",
] }
-karyon_jsonrpc_macro = { path = "jsonrpc_macro", default-features = false }
+karyon_jsonrpc_macro = { version = "0.1.0", path = "jsonrpc_macro", default-features = false }
log = "0.4.21"
rand = "0.8.5"