aboutsummaryrefslogtreecommitdiff
path: root/jsonrpc/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-06-30 20:03:02 +0200
committerhozan23 <hozan23@karyontech.net>2024-06-30 20:03:02 +0200
commit3c55168b72c022b618822c7993b7692f583506db (patch)
tree146c03f6cc19956ec0acfb7ba26a6202cb5a9647 /jsonrpc/Cargo.toml
parent2ec4d4a3c3779dc016c8437891f825a54a805808 (diff)
jsonrpc: remove redundant macro codes in the main crate and clean up
internal proc macros
Diffstat (limited to 'jsonrpc/Cargo.toml')
-rw-r--r--jsonrpc/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/jsonrpc/Cargo.toml b/jsonrpc/Cargo.toml
index 41017fc..35053cd 100644
--- a/jsonrpc/Cargo.toml
+++ b/jsonrpc/Cargo.toml
@@ -33,7 +33,7 @@ tokio = [
karyon_core = { version = "0.1.5", path = "../core", default-features = false }
karyon_net = { version = "0.1.5", path = "../net", default-features = false }
-karyon_jsonrpc_macro = { version = "0.1.5", path = "jsonrpc_macro", default-features = false }
+karyon_jsonrpc_macro = { version = "0.1.5", path = "impl", default-features = false }
log = "0.4.21"
rand = "0.8.5"