aboutsummaryrefslogtreecommitdiff
path: root/jsonrpc/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-05-19 23:41:31 +0200
committerhozan23 <hozan23@karyontech.net>2024-05-19 23:41:31 +0200
commitf6f44784fff5488bb59d563ee7ff7b94c08a48c1 (patch)
tree63fa6fa0d620748a92d819f4773773ea9d53afc5 /jsonrpc/Cargo.toml
parenta6016c7eeb11fc8aeaa1a3b160b970b15362695d (diff)
use cargo features to enable/disable protocols for net crate
Diffstat (limited to 'jsonrpc/Cargo.toml')
-rw-r--r--jsonrpc/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/jsonrpc/Cargo.toml b/jsonrpc/Cargo.toml
index cf49d6e..719543e 100644
--- a/jsonrpc/Cargo.toml
+++ b/jsonrpc/Cargo.toml
@@ -22,7 +22,12 @@ tokio = [
[dependencies]
karyon_core = { workspace = true, default-features = false }
-karyon_net = { workspace = true, default-features = false }
+karyon_net = { workspace = true, default-features = false, features = [
+ "tcp",
+ "unix",
+ "tls",
+ "ws",
+] }
karyon_jsonrpc_macro = { path = "jsonrpc_macro", default-features = false }
@@ -32,7 +37,6 @@ async-tungstenite = { version = "0.25.0", default-features = false }
serde = { version = "1.0.197", features = ["derive"] }
serde_json = "1.0.114"
thiserror = "1.0.58"
-memchr = "2.7.1"
async-trait = "0.1.77"
futures-rustls = { version = "0.25.1", optional = true }