aboutsummaryrefslogtreecommitdiff
path: root/jsonrpc/jsonrpc_macro/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-05-19 22:18:06 +0200
committerhozan23 <hozan23@karyontech.net>2024-05-19 22:18:06 +0200
commit1c520b20f70ddbdab885ec6c4bf5c87893a26eb4 (patch)
tree0e51b047e1df0b29fecdc5c39b200d5ecca520ef /jsonrpc/jsonrpc_macro/Cargo.toml
parent41ceed49285b4082477a83d7dda02fbfb3f96b2a (diff)
jsonrpc: remove jsonrpc_internal crate
Diffstat (limited to 'jsonrpc/jsonrpc_macro/Cargo.toml')
-rw-r--r--jsonrpc/jsonrpc_macro/Cargo.toml9
1 files changed, 3 insertions, 6 deletions
diff --git a/jsonrpc/jsonrpc_macro/Cargo.toml b/jsonrpc/jsonrpc_macro/Cargo.toml
index 17140c5..f0af550 100644
--- a/jsonrpc/jsonrpc_macro/Cargo.toml
+++ b/jsonrpc/jsonrpc_macro/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "karyon_jsonrpc_macro"
-version.workspace = true
+version.workspace = true
edition.workspace = true
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -10,15 +10,12 @@ proc-macro = true
[features]
default = ["smol"]
-smol = ["karyon_jsonrpc_internal/smol"]
-tokio = ["karyon_jsonrpc_internal/tokio"]
+smol = []
+tokio = []
[dependencies]
-karyon_jsonrpc_internal = { path = "../jsonrpc_internal", default-features = false }
-
proc-macro2 = "1.0"
quote = "1.0"
syn = { version = "1.0", features = ["full"] }
serde_json = "1.0.114"
-