aboutsummaryrefslogtreecommitdiff
path: root/net/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-05-27 00:48:15 +0200
committerhozan23 <hozan23@karyontech.net>2024-05-27 00:48:15 +0200
commit3acb724ba1aafeaf37e24dada7c769bb4066444a (patch)
treede80b01229ce133334176694571fbdf4a49402b6 /net/Cargo.toml
parente022b2b77e3e98f0f444f637f96e74e6a6f990cf (diff)
net: add serde feature for serializing & deserializing Endpoints
Diffstat (limited to 'net/Cargo.toml')
-rw-r--r--net/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/net/Cargo.toml b/net/Cargo.toml
index 3206a0f..01a54a7 100644
--- a/net/Cargo.toml
+++ b/net/Cargo.toml
@@ -32,6 +32,7 @@ tokio = [
# TODO: use tls feature
"tokio-rustls",
]
+serde = ["dep:serde"]
[dependencies]
@@ -58,5 +59,8 @@ futures-rustls = { version = "0.25.1", optional = true }
tokio-rustls = { version = "0.26.0", optional = true }
tokio = { version = "1.37.0", features = ["io-util"], optional = true }
+# serde
+serde = { version = "1.0.197", features = ["derive"], optional = true }
+
[dev-dependencies]
smol = "2.0.0"