aboutsummaryrefslogtreecommitdiff
path: root/p2p/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@proton.me>2023-11-28 22:41:33 +0300
committerhozan23 <hozan23@proton.me>2023-11-28 22:41:33 +0300
commit98a1de91a2dae06323558422c239e5a45fc86e7b (patch)
tree38c640248824fcb3b4ca5ba12df47c13ef26ccda /p2p/Cargo.toml
parentca2a5f8bbb6983d9555abd10eaaf86950b794957 (diff)
implement TLS for inbound and outbound connections
Diffstat (limited to 'p2p/Cargo.toml')
-rw-r--r--p2p/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/p2p/Cargo.toml b/p2p/Cargo.toml
index 98b700e..315983b 100644
--- a/p2p/Cargo.toml
+++ b/p2p/Cargo.toml
@@ -20,6 +20,12 @@ thiserror = "1.0.47"
semver = "1.0.20"
sha2 = "0.10.8"
+# tls
+async-rustls = { version = "0.4.1", features = ["dangerous_configuration"] }
+rcgen = "0.11.3"
+yasna = "0.5.2"
+x509-parser = "0.15.1"
+
[[example]]
name = "peer"
path = "examples/peer.rs"