aboutsummaryrefslogtreecommitdiff
path: root/p2p/examples/monitor/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-05-27 00:59:23 +0200
committerhozan23 <hozan23@karyontech.net>2024-05-27 00:59:23 +0200
commitd1c816660c0583db33d160e2ef3e980bef0d5a85 (patch)
tree9eb06e6dbfbe34c6c2f85eee8d2e337b155be103 /p2p/examples/monitor/Cargo.toml
parent385d53ec53e750e342cce78edb793958edf5133e (diff)
p2p: WIP rpc server implementation for the p2p monitor
Diffstat (limited to 'p2p/examples/monitor/Cargo.toml')
-rw-r--r--p2p/examples/monitor/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/p2p/examples/monitor/Cargo.toml b/p2p/examples/monitor/Cargo.toml
new file mode 100644
index 0000000..b323ed1
--- /dev/null
+++ b/p2p/examples/monitor/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+name = "monitor"
+version = "0.1.0"
+edition = "2021"
+
+[workspace]
+
+[dependencies]
+karyon_core = { path = "../../../core", features = ["crypto"] }
+karyon_p2p = { path = "../../", features = ["serde"] }
+karyon_jsonrpc = { path = "../../../jsonrpc", features = ["ws"] }
+clap = { version = "4.5.4", features = ["derive"] }
+ctrlc = "3.4.4"
+env_logger = "0.11.3"
+log = "0.4.21"
+serde = { version = "1.0.203", features = ["derive"] }
+smol = "2.0.0"
+serde_json = "1.0.117"
+easy-parallel = "3.3.1"
+ringbuffer = "0.15.0"
+
+[[bin]]
+name = "client"
+path = "src/client.rs"
+
+[[bin]]
+name = "monitor"
+path = "src/main.rs"
+