aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 14 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aa71954..aa5ba29 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,12 +1,17 @@
-[package]
-name = "karyons"
-version = "0.1.0"
-edition = "2021"
-
[workspace]
-
members = [
- "karyons_core",
- "karyons_net",
- "karyons_p2p",
+ "core",
+ "net",
+ "p2p",
]
+
+resolver = "2"
+
+[workspace.package]
+version = "0.1.0"
+edition = "2021"
+
+[workspace.dependencies]
+karyons_core = { path = "core" }
+karyons_net = { path = "net" }
+karyons_p2p = { path = "p2p" }