aboutsummaryrefslogtreecommitdiff
path: root/core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml28
1 files changed, 15 insertions, 13 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index c8e2b8d..4bb7f4f 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -1,13 +1,15 @@
[package]
name = "karyon_core"
-version.workspace = true
+version.workspace = true
edition.workspace = true
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[features]
+default = ["smol"]
+crypto = ["dep:ed25519-dalek"]
+tokio = ["dep:tokio"]
+smol = ["dep:smol", "dep:async-process"]
[dependencies]
-smol = "2.0.0"
pin-project-lite = "0.2.13"
log = "0.4.21"
bincode = "2.0.0-rc.3"
@@ -15,15 +17,15 @@ chrono = "0.4.35"
rand = "0.8.5"
thiserror = "1.0.58"
dirs = "5.0.1"
-async-task = "4.7.0"
-async-lock = "3.3.0"
-async-process = "2.1.0"
-
-ed25519-dalek = { version = "2.1.1", features = ["rand_core"], optional = true}
+async-channel = "2.2.0"
+# crypto feature deps
+ed25519-dalek = { version = "2.1.1", features = ["rand_core"], optional = true }
-[features]
-default = []
-crypto = ["dep:ed25519-dalek"]
-
+# smol feature deps
+async-process = { version = "2.1.0", optional = true }
+smol = { version = "2.0.0", optional = true }
+# tokio feature deps
+tokio = { version = "1.37.0", features = ["full"], optional = true }
+once_cell = "1.19.0"