aboutsummaryrefslogtreecommitdiff
path: root/core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml31
1 files changed, 14 insertions, 17 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index 895ddf6..a43537b 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -15,26 +15,23 @@ tokio = ["dep:tokio"]
smol = ["dep:smol", "async-process"]
[dependencies]
-log = "0.4.21"
-thiserror = "1.0.61"
-chrono = "0.4.38"
-rand = "0.8.5"
+log = { workspace = true }
+thiserror = { workspace = true }
+chrono = { workspace = true }
+rand = { workspace = true }
+parking_lot = { workspace = true }
dirs = "5.0.1"
-parking_lot = "0.12.3"
-once_cell = "1.19.0"
+once_cell = { workspace = true }
-# async
-async-channel = "2.3.1"
-pin-project-lite = "0.2.14"
-async-process = { version = "2.2.3", optional = true }
-smol = { version = "2.0.0", optional = true }
-tokio = { version = "1.38.0", features = ["full"], optional = true }
-futures-util = { version = "0.3.5", features = [
- "alloc",
+async-channel = { workspace = true }
+pin-project-lite = { workspace = true }
+async-process = { workspace = true, optional = true }
+smol = { workspace = true, optional = true }
+tokio = { workspace = true, features = ["full"], optional = true }
+futures-util = { workspace = true, features = [
+ "alloc",
], default-features = false }
-# encode
-bincode = "2.0.0-rc.3"
+bincode = { workspace = true }
-# crypto
ed25519-dalek = { version = "2.1.1", features = ["rand_core"], optional = true }