aboutsummaryrefslogtreecommitdiff
path: root/karyons_net/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'karyons_net/Cargo.toml')
-rw-r--r--karyons_net/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/karyons_net/Cargo.toml b/karyons_net/Cargo.toml
new file mode 100644
index 0000000..70e1917
--- /dev/null
+++ b/karyons_net/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "karyons_net"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+karyons_core = { path = "../karyons_core" }
+
+smol = "1.3.0"
+async-trait = "0.1.74"
+pin-project-lite = "0.2.13"
+log = "0.4.20"
+bincode = { version="2.0.0-rc.3", features = ["derive"]}
+chrono = "0.4.30"
+rand = "0.8.5"
+thiserror = "1.0.47"
+dirs = "5.0.1"
+url = "2.4.1"
+