aboutsummaryrefslogtreecommitdiff
path: root/karyons_p2p/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'karyons_p2p/Cargo.toml')
-rw-r--r--karyons_p2p/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/karyons_p2p/Cargo.toml b/karyons_p2p/Cargo.toml
new file mode 100644
index 0000000..1c2a5aa
--- /dev/null
+++ b/karyons_p2p/Cargo.toml
@@ -0,0 +1,41 @@
+[package]
+name = "karyons_p2p"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+karyons_core = { path = "../karyons_core" }
+karyons_net = { path = "../karyons_net" }
+
+async-trait = "0.1.73"
+smol = "1.3.0"
+futures-util = {version = "0.3.5", features=["std"], default-features = false }
+log = "0.4.20"
+chrono = "0.4.30"
+bincode = { version="2.0.0-rc.3", features = ["derive"]}
+rand = "0.8.5"
+thiserror = "1.0.47"
+semver = "1.0.20"
+sha2 = "0.10.8"
+
+[[example]]
+name = "peer"
+path = "examples/peer.rs"
+
+[[example]]
+name = "chat"
+path = "examples/chat.rs"
+
+[[example]]
+name = "monitor"
+path = "examples/monitor.rs"
+
+[dev-dependencies]
+async-std = "1.12.0"
+clap = { version = "4.4.6", features = ["derive"] }
+ctrlc = "3.4.1"
+easy-parallel = "3.3.1"
+env_logger = "0.10.0"
+