aboutsummaryrefslogtreecommitdiff
path: root/net/async_rustls/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'net/async_rustls/Cargo.toml')
-rw-r--r--net/async_rustls/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/net/async_rustls/Cargo.toml b/net/async_rustls/Cargo.toml
new file mode 100644
index 0000000..0d40e8a
--- /dev/null
+++ b/net/async_rustls/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "karyon_async_rustls"
+description = "Internal crate for Karyon library."
+version.workspace = true
+edition.workspace = true
+homepage.workspace = true
+repository.workspace = true
+license.workspace = true
+authors.workspace = true
+
+[features]
+default = ["smol"]
+smol = ["futures-rustls"]
+tokio = ["tokio-rustls"]
+
+[dependencies]
+futures-rustls = { version = "0.25.1", optional = true }
+tokio-rustls = { version = "0.26.0", optional = true }
+