aboutsummaryrefslogtreecommitdiff
path: root/jsonrpc/jsonrpc_macro/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-06-30 20:03:02 +0200
committerhozan23 <hozan23@karyontech.net>2024-06-30 20:03:02 +0200
commit3c55168b72c022b618822c7993b7692f583506db (patch)
tree146c03f6cc19956ec0acfb7ba26a6202cb5a9647 /jsonrpc/jsonrpc_macro/Cargo.toml
parent2ec4d4a3c3779dc016c8437891f825a54a805808 (diff)
jsonrpc: remove redundant macro codes in the main crate and clean up
internal proc macros
Diffstat (limited to 'jsonrpc/jsonrpc_macro/Cargo.toml')
-rw-r--r--jsonrpc/jsonrpc_macro/Cargo.toml26
1 files changed, 0 insertions, 26 deletions
diff --git a/jsonrpc/jsonrpc_macro/Cargo.toml b/jsonrpc/jsonrpc_macro/Cargo.toml
deleted file mode 100644
index cf001e1..0000000
--- a/jsonrpc/jsonrpc_macro/Cargo.toml
+++ /dev/null
@@ -1,26 +0,0 @@
-[package]
-name = "karyon_jsonrpc_macro"
-description = "Internal crate for Karyon library."
-version.workspace = true
-edition.workspace = true
-homepage.workspace = true
-repository.workspace = true
-license.workspace = true
-authors.workspace = true
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[lib]
-proc-macro = true
-
-[features]
-default = ["smol"]
-smol = []
-tokio = []
-
-[dependencies]
-proc-macro2 = "1.0"
-quote = "1.0"
-syn = { version = "2.0", features = ["full"] }
-
-serde_json = "1.0.117"