aboutsummaryrefslogtreecommitdiff
path: root/p2p/examples/tokio-example/Cargo.toml
diff options
context:
space:
mode:
authorhozan23 <hozan23@karyontech.net>2024-05-19 22:20:03 +0200
committerhozan23 <hozan23@karyontech.net>2024-05-19 22:20:03 +0200
commita6016c7eeb11fc8aeaa1a3b160b970b15362695d (patch)
treea872c02076836811257b59ce7d88f9ef5a85f5ed /p2p/examples/tokio-example/Cargo.toml
parent1c520b20f70ddbdab885ec6c4bf5c87893a26eb4 (diff)
add tokio examples to p2p, jsonrpc, and net crates
Diffstat (limited to 'p2p/examples/tokio-example/Cargo.toml')
-rw-r--r--p2p/examples/tokio-example/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/p2p/examples/tokio-example/Cargo.toml b/p2p/examples/tokio-example/Cargo.toml
new file mode 100644
index 0000000..5604677
--- /dev/null
+++ b/p2p/examples/tokio-example/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "tokio-example"
+version = "0.1.0"
+edition = "2021"
+
+[workspace]
+
+[dependencies]
+karyon_p2p = { path = "../../", default-features = false, features = ["tokio"] }
+async-channel = "2.3.1"
+tokio = { version = "1.37.0", features = ["full"] }
+clap = { version = "4.5.4", features = ["derive"] }
+ctrlc = "3.4.4"
+env_logger = "0.11.3"