aboutsummaryrefslogtreecommitdiff
path: root/p2p/examples/tokio-example/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'p2p/examples/tokio-example/Cargo.toml')
-rw-r--r--p2p/examples/tokio-example/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/p2p/examples/tokio-example/Cargo.toml b/p2p/examples/tokio-example/Cargo.toml
new file mode 100644
index 0000000..5604677
--- /dev/null
+++ b/p2p/examples/tokio-example/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "tokio-example"
+version = "0.1.0"
+edition = "2021"
+
+[workspace]
+
+[dependencies]
+karyon_p2p = { path = "../../", default-features = false, features = ["tokio"] }
+async-channel = "2.3.1"
+tokio = { version = "1.37.0", features = ["full"] }
+clap = { version = "4.5.4", features = ["derive"] }
+ctrlc = "3.4.4"
+env_logger = "0.11.3"